Author Topic: Edgwick Lathe  (Read 3800 times)

Offline mat9900

  • Jr. Member
  • **
  • Posts: 14
Edgwick Lathe
« on: February 16, 2017, 03:31:03 PM »
Hi all, just joined the forum here as iv bought myself a new toy in the shape of an Edgwick mk1 from Ebay:-
http://www.ebay.co.uk/itm/Edgwick-Manual-Lathe-/162373099422?hash=item25ce30df9e%3Ag%3ApJ8AAOSwjDZYiv0f&autorefresh=true&nma=true&si=5tpfgJCqG94ZA%252BygLgpEG7p3Rbc%253D&orig_cvip=true&rt=nc&_trksid=p2047675.l2557

As you can see I didnt give a lot for it, have fetched it and ran it up and all seems to work ok other than the clamp on the tailstock, so so far so good!
I am intending to do a restoration on her, so will surely be on here asking for help/guidance! Matt

Offline tom osselton

  • Hero Member
  • *****
  • Posts: 860
  • Country: ca
Re: Edgwick Lathe
« Reply #1 on: February 16, 2017, 03:47:55 PM »
Nice find! You should be happy with it.

Offline awemawson

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 5560
  • Country: gb
  • East Sussex, UK
Re: Edgwick Lathe
« Reply #2 on: February 16, 2017, 04:00:43 PM »
Matt, welcome to the forum. A few here have Edgwick lathes so you should fit in just nicely  :clap:

Why don't you pop over to the introductions sub forum and tell us a bit about yourself and why you want a lathe (Well really WHO wouldn't want a lathe  :lol: )
Andrew Mawson
East Sussex

Offline mattinker

  • Hero Member
  • *****
  • Posts: 1053
  • Country: fr
Re: Edgwick Lathe
« Reply #3 on: February 16, 2017, 06:08:06 PM »
Hi all, just joined the forum here as iv bought myself a new toy in the shape of an Edgwick mk1 from Ebay:-
http://www.ebay.co.uk/itm/Edgwick-Manual-Lathe-/162373099422?hash=item25ce30df9e%3Ag%3ApJ8AAOSwjDZYiv0f&autorefresh=true&nma=true&si=5tpfgJCqG94ZA%252BygLgpEG7p3Rbc%253D&orig_cvip=true&rt=nc&_trksid=p2047675.l2557

I'm one of the other Edgwick owners. I tried to see the advertisment on eBay for your lathe, but nothing is available as the sale is closed.So, how about some photos? I think you are the fifth Edgewick owner on here!

Looking forward to hearing more about your lathe, maybe some photos?

All the best, Matthew.

Offline mat9900

  • Jr. Member
  • **
  • Posts: 14
Re: Edgwick Lathe
« Reply #4 on: February 16, 2017, 07:29:20 PM »
I thought the link worked but you have to scroll down a bit-apologies if I'm wrong. I will try and get some pics up tomorrow, but great to hear there are other edgwick owners on here! Thanks, Matt

Offline mattinker

  • Hero Member
  • *****
  • Posts: 1053
  • Country: fr
Re: Edgwick Lathe
« Reply #5 on: February 16, 2017, 07:36:18 PM »
I thought the link worked but you have to scroll down a bit-apologies if I'm wrong. I will try and get some pics up tomorrow, but great to hear there are other edgwick owners on here! Thanks, Matt
I went back and scrolled dow, sure enough, there it was! Photo copied!

Regards, Matthew

Offline John Stevenson

  • In Memoriam
  • Hero Member
  • *****
  • Posts: 1645
  • Nottingham, England.
Re: Edgwick Lathe
« Reply #6 on: February 16, 2017, 08:22:49 PM »
Used to have one 2 or 3 lathes ago but it was very badly worn and probably gone for scrap now. Adv had a few of the bits off it, chucks, steadies etc.

Made a couple of cross slide nuts for an Edgwick ? a while ago ?


Pressed an insert into the original nut [ too idle to make a new one ] and supplied a spare insert as well.
John Stevenson

Offline AdeV

  • Madmodder Committee
  • Hero Member
  • *****
  • Posts: 1983
  • Country: gb
Re: Edgwick Lathe
« Reply #7 on: February 17, 2017, 03:40:06 AM »
At this rate, we'll have to set up an Edgwick Owner's club!  :)

I bought mine a few years back (paid a bit more than you did too, but still cheap for such a large and capable lathe). I like the fact it'll do a wide range of both metric and imperial threads from the gearbox, no change gears to mess around with, and it's got a decent spindle bore. You eventually get used to the fact it'll only do 670rpm flat out...

I made a QCTP for mine fairly early into my ownership, I couldn't get on with the oem 4-way tool post.

I might be able to sort you out a replacement tailstock clamp, if yours is missing bits... I have a whole spare tailstock. Check for wear in the tailstock nut - I have about a full turn of backlash in mine, and it's only a matter of time before it tears the threads out.... they've worn very thin. Still.... it hasn't let me down yet!

Looking forward to the restoration thread :D I'd particularly like to see pictures if you have a go at the brake/clutch.... my brake doesn't work, which makes threading to shoulders an "interesting" challenge...
Cheers!
Ade.
--
Location: Wallasey, Merseyside. A long way from anywhere.
Or: Zhengzhou, China. An even longer way from anywhere...
Skype: adev73

Offline mat9900

  • Jr. Member
  • **
  • Posts: 14
Re: Edgwick Lathe
« Reply #8 on: February 17, 2017, 04:40:40 AM »
Hi AdeV, great to hear from another owner. When I get to that tailstock il give you a shout! Yes it does look a capable lathe- I have a Portass dreadnought which has taught me lots, but is too small for a lot of the work I wish to do, hence iv gone for the Edgwick.
Having threaded numerous times with the Portass changewheels I am definitely keen on the Edgwick screwcutting gearbox!
You say your top spindle speed is 670? Im pretty sure mine is 1000rpm but will have a better look when im next with it, although some of the numbers on the speed selectors are worn and hard to read. It definitely has a 5hp 1440rpm motor on it if that makes any difference.

Also thanks to John Stevenson for that info regarding cross slide nuts- again whn I get that far I will probably give you a shout- I can see joining this forum was one of my better ideas!

Offline mattinker

  • Hero Member
  • *****
  • Posts: 1053
  • Country: fr
Re: Edgwick Lathe
« Reply #9 on: February 17, 2017, 06:18:43 AM »
Your a lucky Guy! You have the 1440rpm 5 horse motor which is why you have 1000RPM, that sounds like a great lathe. I've had my Edgwick about a year now, but I haven't got much done on it! I need to get back to getting it running properly, putting a reversing switch on it and a quick change tool post that I've found for it!

All the best, Matthew

Offline AdeV

  • Madmodder Committee
  • Hero Member
  • *****
  • Posts: 1983
  • Country: gb
Re: Edgwick Lathe
« Reply #10 on: February 17, 2017, 06:37:09 AM »
Hi AdeV, great to hear from another owner. When I get to that tailstock il give you a shout! Yes it does look a capable lathe- I have a Portass dreadnought which has taught me lots, but is too small for a lot of the work I wish to do, hence iv gone for the Edgwick.
Having threaded numerous times with the Portass changewheels I am definitely keen on the Edgwick screwcutting gearbox!
You say your top spindle speed is 670? Im pretty sure mine is 1000rpm but will have a better look when im next with it, although some of the numbers on the speed selectors are worn and hard to read. It definitely has a 5hp 1440rpm motor on it if that makes any difference.

Also thanks to John Stevenson for that info regarding cross slide nuts- again whn I get that far I will probably give you a shout- I can see joining this forum was one of my better ideas!

They're certainly good heavy capable lathes. Using insert tooling, I've taken 60 thou cuts (120thou off the diameter) in steel, and it's not batted an eyelid. Of course, you have to stop and let the metal cool down for a while after such abuse... I exclusively use insert tooling in mine, because I'm hopeless at grinding HSS... and Chronos do reasonably priced inserts/holders these days.

Yes, you've got the better motor there, mine's only the 3hp, not sure of it's top speed, but that does work out as 670 on the spindle in top gear. The slowest mine will go is 17rpm - great for threading, your slowest speed will be a bit faster than that. You may find the selector suggests 670 is your top speed, ignore it as you have the faster motor.

The only "gotcha" I'd say you really need to watch out for - when you go from powered drive to neutral (the big lever on the apron), watch you don't pull it past neutral as you'll end up engaging the screwcutting drive - which moves the carriage even faster! Don't ask me how I know this!! The resulting tool-crash bent a 1.5" steel bar, destroyed an insert holder, and put a decent dent in my QCTP. Fortunately, it didn't do any other damage...
Cheers!
Ade.
--
Location: Wallasey, Merseyside. A long way from anywhere.
Or: Zhengzhou, China. An even longer way from anywhere...
Skype: adev73

Offline mat9900

  • Jr. Member
  • **
  • Posts: 14
Re: Edgwick Lathe
« Reply #11 on: February 17, 2017, 06:20:49 PM »
Hi again, I have some pics of the lathe but when I try and upload I get the following message:- The madmodder.net page isnít working.    madmodder.net is currently unable to handle this request.   HTTP ERROR 500
Any ideas what im doing wrong?
Anyway the writing on my speed selector is very worn and hard to read, but think it says 19 rpm as the slowest, 1000 as the fastest- if anyone knows better im all ears!
Also I found the serial number :- DL 2556 if that means anything to anyone?
Thanks for that "gotcha" info- now iv looked at the lever I see how easy that would be to do-i will try to be careful!

Offline mattinker

  • Hero Member
  • *****
  • Posts: 1053
  • Country: fr
Re: Edgwick Lathe
« Reply #12 on: February 17, 2017, 07:31:23 PM »
Speeds when fitted with 1450rpm motor.

Regards, Matthew


Offline AdeV

  • Madmodder Committee
  • Hero Member
  • *****
  • Posts: 1983
  • Country: gb
Re: Edgwick Lathe
« Reply #13 on: February 18, 2017, 07:40:45 AM »
I just noticed in the eBay picture that yours came with a 3-jaw chuck held in the 4-jaw.... exactly the same as mine! I've been lucky and since managed to acquire a 3-jaw with an Edgwick fitting (I think it came from John, or it might have come with the spare parts I bought from someone who scrapped one), the chucks are a bit of a pain to change - no handy camlock fitting! Seems strange really, the tailstock has one of the  best clamping systems out there (captive lever, no spanner to mislay), one of the most versatile gearboxes of any similar-age lathe, yet the chuck is a complete batstard to change... hey ho. I ran mine as I found it for a while, but I did have a small accident one time with the double-chuck arrangement, so I've never done it since.
Cheers!
Ade.
--
Location: Wallasey, Merseyside. A long way from anywhere.
Or: Zhengzhou, China. An even longer way from anywhere...
Skype: adev73

Offline mat9900

  • Jr. Member
  • **
  • Posts: 14
Re: Edgwick Lathe
« Reply #14 on: February 18, 2017, 03:37:55 PM »
Hi again, thanks for that speed info Matthew- that makes sense, due to the wear on the numbers what I thought was 19 is 39 on the next set of 3- my mistake.
And AdeV, yes I thought the chuck mounting arrangement was strange, but thought perhaps I would make a backplate for that 3 jaw (or another 3 jaw I have in my collection if its better) at some point.

Offline Biggles

  • Full Member
  • ***
  • Posts: 218
  • Country: gb
Re: Edgwick Lathe
« Reply #15 on: February 19, 2017, 03:31:13 PM »
Welcome Matt.  :ddb:

Offline mat9900

  • Jr. Member
  • **
  • Posts: 14
Re: Edgwick Lathe
« Reply #16 on: February 23, 2017, 08:43:41 AM »
Thanks for that Biggles.
I have finally managed to get a photo of it uploaded- still on the trailer having fetched it though!

Offline awemawson

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 5560
  • Country: gb
  • East Sussex, UK
Re: Edgwick Lathe
« Reply #17 on: February 23, 2017, 09:06:55 AM »
Now there's a meaty bit of iron.

Should be ideal for making those tiny watch staffs   :clap:
Andrew Mawson
East Sussex

Offline John Stevenson

  • In Memoriam
  • Hero Member
  • *****
  • Posts: 1645
  • Nottingham, England.
Re: Edgwick Lathe
« Reply #18 on: February 23, 2017, 11:15:55 AM »
Think I still have a fixed steady for one of these lathes. I can just see the top of a steady under a bench but it's going to be a two day job with a rope round my waist and a trail of breadcrumbs before I can liberate it.
John Stevenson

Offline awemawson

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 5560
  • Country: gb
  • East Sussex, UK
Re: Edgwick Lathe
« Reply #19 on: February 23, 2017, 11:18:10 AM »
Still clearing out John? Did those rollers get anywhere near a pallet yet ?
Andrew Mawson
East Sussex

Offline mat9900

  • Jr. Member
  • **
  • Posts: 14
Re: Edgwick Lathe
« Reply #20 on: February 28, 2017, 02:13:27 PM »
Back again!  Iv got around to looking at the non-working tailstock clamp- but being thick I cant see how it is supposed to work! Iv uploaded a pic of the underside of it- do any of the other Edgwick owners on here know whats missing/wrong that makes it "pull up" when rotated?

Offline awemawson

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 5560
  • Country: gb
  • East Sussex, UK
Re: Edgwick Lathe
« Reply #21 on: February 28, 2017, 02:25:46 PM »
Is that an eccentric cam on the end of the locking shaft? If so presumably it forces the 'shoe' in which it rides against whatever is next to it  :thumbup:
Andrew Mawson
East Sussex

Offline AdeV

  • Madmodder Committee
  • Hero Member
  • *****
  • Posts: 1983
  • Country: gb
Re: Edgwick Lathe
« Reply #22 on: February 28, 2017, 07:16:49 PM »
If I'm out of bed early enough tomorrow, I'll nip down the unit and have a look at mine - which, as it works properly, should give us an answer  :thumbup:
Cheers!
Ade.
--
Location: Wallasey, Merseyside. A long way from anywhere.
Or: Zhengzhou, China. An even longer way from anywhere...
Skype: adev73

Offline mat9900

  • Jr. Member
  • **
  • Posts: 14
Re: Edgwick Lathe
« Reply #23 on: March 01, 2017, 02:47:26 PM »
Thanks Ade. I don't think its a cam on the end- the unit need to pull vertically upwards to clamp against the underside of the bed- not sideways.  So being as thick as I am I can't see how it is supposed to do that. Hopefully Ade can shed some light on the matter..............

Offline philf

  • Hero Member
  • *****
  • Posts: 800
  • Country: gb
Re: Edgwick Lathe
« Reply #24 on: March 01, 2017, 04:47:17 PM »
I don't think its a cam on the end- the unit need to pull vertically upwards to clamp against the underside of the bed- not sideways. 

Matt,

This is a typical tailstock clamp. As you can see the clamp plate is pulled up by an eccentric when the locking handle is turned.



I guess your Edgwick will use a similar system. Often there's a nylock nut under the plate to adjust the clamping point.

[Edit: I see from Ade's photos it's nothing like the one above.

A bit of a mystery as to why the screw doesn't turn when you operate the handle.

Or perhaps it does and that may be the problem.]

Phil.
« Last Edit: July 13, 2017, 12:56:46 PM by philf »
Phil Fern
Location: Marple, Cheshire